I'm up and Running!!
Close

I'm up and Running!!

This is a discussion on I'm up and Running!! within the General forums, part of the Caferacer.net Forums category; well to make a long story short.... I picked up a matching numbers 1972 Bonnie cheap and was told the engine had been rebuilt, from ...

Results 1 to 4 of 4
  1. #1
    Chikor's Avatar
    Join Date
    Mar 2002
    Posts
    896

    I'm up and Running!!

    well to make a long story short.... I picked up a matching numbers 1972 Bonnie cheap and was told the engine had been rebuilt, from what I can see it has been, rebuilt the carbs put on smoe stock things to relieve it of bad 1970's add-ons and she is alive and well with not a puff of ol' blue.... I'm so proud of her!! OK it's been two years since I have had a bike on the road.... worked on lots and road lots but not one of mine!!!


  2. #2
    Moderator ROSKO's Avatar
    Join Date
    Feb 2005
    Location
    New York, New York, Australia.
    Posts
    3,065
    CHIKooooooooooooooR!

  3. #3
    Senior Member Swagger's Avatar
    Join Date
    Aug 2006
    Location
    Portland, Oregon, USA.
    Posts
    2,047
    Looks like a great start!
    Great spirits have always found violent opposition from mediocrities. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices, but honestly and courageously uses his intelligence and fulfills the duty to express the results of his thought in clear form.
    ~Albert Einstein

  4. Remove Advertisements
    CafeRacer.net
    Advertisements
     

  5. #4
    Chikor's Avatar
    Join Date
    Mar 2002
    Posts
    896
    I'm gonna ride it as is for a bit then when the chop is done I will take it apart and restore it..... maybe, I kinda like it rough....

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. cl125s not running right
    By jaguar in forum Technical
    Replies: 0
    Last Post: 06-24-2010, 09:20 AM
  2. non running cb350?
    By onesojourner in forum General
    Replies: 28
    Last Post: 09-21-2009, 06:50 PM
  3. just got it running, tunning help
    By clutchkith in forum Technical
    Replies: 8
    Last Post: 04-06-2009, 12:12 PM
  4. Running lean and not so mean
    By Pete Casper in forum Technical
    Replies: 16
    Last Post: 04-09-2007, 06:56 PM
  5. running around
    By joe c in forum General
    Replies: 1
    Last Post: 06-02-2003, 09:20 PM