Cafe Racer Forum banner

21 - 40 of 40 Posts

·
Registered
Joined
·
10,485 Posts
Discussion Starter #21
So Venhill said yes?
Yeah, it is really isnt that expensive either.
Probably means I will not ride it this season though based on time line.
Im okay with that though.
 

·
Registered
Joined
·
10,485 Posts
Discussion Starter #22
IMG_20190922_195511.jpg
Finally got some time to mess with the carbs.
Gaskets were perfect. Nice price and killer quality. Super happy.

Saw a deal on some JIS screw drivers a while ago, and this is the first time I get to use them!
Funny that it was on a Bimota, and not my normal garage of Hondas

IMG_20190922_200128.jpg

Pro tip while rebuilding carbs.
Always use a spill proof glass for your drink....
IMG_20190922_195611.jpg

All ready to go back on.
IMG_20190922_205524.jpg

Ran into one small issue.
When putting the float bowls on, I assumed that I had mixed up the order, as the drain was not pointing in the correct direction.
I "corrected" this, but found out I was wrong when I went to install the carbs.....
The drain hits the shock mount.
Gotalove this stuff.
IMG_20190922_205924.jpg
 

·
Registered
Joined
·
10,485 Posts
Discussion Starter #24
that would be a bimota.
Yup.
but the simple swapping of bowls around gets everything tightly packed in here.
better then having some one off carb that you can't service
 

·
Registered
Joined
·
10,485 Posts
Discussion Starter #29
Bike moved under its own power yesterday!

Got everything buttoned up and it fired right up.
Took it to get fuel and was great.

Tried to take it on a quicker blast to open her up a bit and failed.
Seems to be starving for fuel.

Suspect the silly vacuum fuel pump thing, and a bad filter.
Changed those last night, but was too late to take a road test.
Put a couple of miles on it hoping in vain that it was just a slug of bad fuel or something.

Bimota After.jpg Mileage.jpg
 
  • Like
Reactions: jcw

·
Registered
Joined
·
2,563 Posts
Bike moved under its own power yesterday!

Got everything buttoned up and it fired right up.
Took it to get fuel and was great.

Tried to take it on a quicker blast to open her up a bit and failed.
Seems to be starving for fuel.

Suspect the silly vacuum fuel pump thing, and a bad filter.
Changed those last night, but was too late to take a road test.
Put a couple of miles on it hoping in vain that it was just a slug of bad fuel or something.

View attachment 99333 View attachment 99335
Watch the diaphragms on the CV slider. I had a buddy that messed them up on every re-tune/rebuild I think most of my rebuilds were fixing his work. Floats and needles can be finicky too.
 

·
Registered
Joined
·
10,485 Posts
Discussion Starter #33
Back from a spin around town.
Still has an issue with the new fuel filter and checked over pump.


Dug into things a bit deeper.
-tank vent is good.
-fuel tap is clean and flowing well.
-vacuum to pump is good.
-pump is clear and appears to be pumping.
-fuel filter is new.
-plugs are all even and good color. All are new NGK as well.


Checked to see if there was a cracked coil. None that I can see.
Will check the spark quality latter.


When Reved in the garage with the airbox on, I don't see the slides moving. Unsure if the vacuum system is hooked up 100%.


Plates rotate to full open with no issues.


Fuel is new high test.


At least I, getting good at taking the tank and seat off....
 

·
Registered
Joined
·
10,485 Posts
Discussion Starter #34
Sounds like I might need to jet the bike.
Ordered some brass and will see.

Also seems that the carb signal lines were not installed correctly.

More to come, if anyone cares.
 

·
Registered
Joined
·
10,485 Posts
Discussion Starter #36
Yep, they all seem perfect.
 

·
Registered
Joined
·
10,485 Posts
Discussion Starter #38
When you siad that the sliders weren't rising, I'd have put money on the diaphragms being split or not seating. Needless to say I'm pretty much scint.
Ended up being the fact I was not reving high enough.
Was just blipping it, and with the open exhaust I didnt want to push things.

I want the neighbors to not hate me.
 

·
Registered
Joined
·
10,485 Posts
Discussion Starter #39
Bimota Water.jpg


Put a couple of miles on it the other day.
Didnt push it as the tires are 20 years old.

Fun bike though.
New Power RS tires showed up yesterday. I accidentally ordered a 190/55 rear instead of the OEM 190/50.
Fingers crossed that it does not cause clearance issues.
 

·
Registered
Joined
·
10,485 Posts
Discussion Starter #40
Had Venhill replicate the throttle cables. One has been damaged.
Not 100% happy with how they came out, but lets hope they make right.

Once the cables are installed the bike is 100% ready to rip when the weather breaks.
Might make it to the RADWood in Philly with the bike.
 
  • Like
Reactions: jcw
21 - 40 of 40 Posts
Top