Cafe Racer Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I'll confess, I'm only 23. That's not necessarily the problem, however I can say I haven't been around long enough to be able to listen to the Triumph in my barn and tell you if it sounds like it should.
It started fine a few days ago, while running it makes a chattering metallic sound... did the ol' screwdriver to the ear trick and thought perhaps the valves slamming open & closed? A strange rapid 'tinking' or chattering is the best I can describe it.
My buddy rode it for a few days, then came cruising in the driveway claiming he had lost a cylinder. Cleaned the carbs (weird clear spherical build up? ...no idea where it came from or what it is as the engine was recently professionally rebuilt)and they bleed beautifully now, went over everything else in the area... Now she won't start. Kicked for 30 minutes, bump starts, everything.
Today my buddy plans to get it started and seek the advice of (older) friends who know what the thing should sound like. Thought I'd ask around here too. I know this is a little vague, hopefully one of the local Triumph guys gets a listen to it today. Any ideas here?
 

·
Premium Member
Joined
·
10,737 Posts
matthew,

hopefully one of the old guys you refer to in west chester is snuffy smith. if not, find him as he has at least 5 triumphs in his collection. also craig charles in abington or jesse morris in phoenixville are knowledgable dudes.

word!

tex

"dude, my boots feel like they are filled with rain slushies!"
 

·
Premium Member
Joined
·
10,737 Posts
then your in good shape. tell him tex said hi!

tex

"dude, my boots feel like they are filled with rain slushies!"
 

·
Registered
Joined
·
13,809 Posts
did you check to see if the valve adjusters had backed off??


they are notorious for that.

jc
 
1 - 5 of 5 Posts
Top